Latency spikes for order entry

Incident Report for QFEX

Resolved

The incident has been resolved.
Further upgrades will occur over the next week to improve P95 latency
Posted May 09, 2025 - 20:15 BST

Investigating

We are currently investigating the issue
Posted May 09, 2025 - 19:43 BST
This incident affected: API Access (trade.qfex.com) and Frontend.