NVDA Price out of Bounds

Incident Report for QFEX

Resolved

This incident has been resolved.
Posted May 29, 2025 - 03:09 BST

Monitoring

Fix has been implemented
Posted May 29, 2025 - 03:09 BST

Update

Fix is being deployed
Posted May 29, 2025 - 02:37 BST

Investigating

Unable to place orders on Nvidia
Posted May 29, 2025 - 02:35 BST
This incident affected: API Access (trade.qfex.com).